Jump to content

Battery not charging


Yurlosin
 Share

Recommended Posts

Using a turnigy nanno tech 950mah 3s when I plug the charger in the screen brightens up but doesn't show the charging sign if I upload the same factory settings to the device it will charge but unplug it and plug back in won't charge again I'm lost on this one

Link to comment
Share on other sites

Yurlosin said:

Using a turnigy nanno tech 950mah 3s when I plug the charger in the screen brightens up but doesn't show the charging sign if I upload the same factory settings to the device it will charge but unplug it and plug back in won't charge again I'm lost on this one



Check the Charging Brightness in Screen tab on EScribe, if 0% set to at least 35% or higher for it to show up

Link to comment
Share on other sites

it has the newest firmware porblem is getting worse last night it read all 3 cells now it is not reading cell1 at all so it will not power up on its own only thing i did was leave it connected to the charger all night i have tried swapping the battery to another board that works fine no luck there maybe a bad trace in the board?

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...
  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...