Jump to content

OK-RMA'd a hotcig V2, new board-same problems, own 3 other DNA200's and the batteries work fine.

Recommended Posts

Hi everyone. 

I recently had to RMA my hotcig V2, as it had started to read batteries that were in perfect balance, as SEVERELY out of balance, cell 1 at 1V, cell 2 at over 5V, and cell 3 anywhere in between. 

I just got the device back today-went to use it-and it has the EXACT same issue. 

Now-I know it is NOT the batteries, as I have tested them with a multimeter and also they read as balanced, and work fine on my Hotcig V1. 

I have even tried converting it to run on dual 18650's like my V1, with batteries that are balanced, and it is reading cell 1 at over 5 volts, and cell 2 at around 2 Volts!

I am really at a loss what to do-I own 3 other DNA200's, that work flawlessly-but this just will not read in balance. 

I have tried different leads, and even as mentioned changing from a 3S Li-PO to a 2S 18650 configuration. 

It is so annoying, as I know evolv have fixed it perfectly-so why is it not functioning? 

The chip is new, it was programmed fairly recently, so it must of been replaced. 

Does anyone, at all, have any idea on how to get this device working? 

It is obviously not the balance tap, as it is still doing it after EVOLV have repaired it. 

This also happens with a completely standard escribe setup-even with default settings it will just not work. 

Please could somebody help me, as I am lost on how to sort this issue out. 

Should I uninstall and reinstall Escribe? It is the only thing I can think of, a Software or firmware issue. 

Kind regards, Conan.

Link to comment
Share on other sites

OH my-it is now sorted. 

At first, it would not work-I gently moved all 4 pins up, and it is reading the 3S LI-Po's in perfect balance now. 

So it was a problem with the balance port-the pins were not making correct contact. It must of got missed as I understand Evolv has a high workload as explained to me. 

But, all in all, am very happy it is now working again-I much prefer the V2 styling to the V1, and it is currently on charge, each cell at 3.42V, in perfect balance. 

So-there was issue at the balance tap-that neither me, or Evolv noticed. 

I can recommend the DNA200 highly, but I can't the Hotcigs. I will be getting another dual 18650 housing for this one, as I feel the 900MAH 3s LI-po dies far too quickly for me. 

Thank you Evolv for sorting out the devices shoddy workmanship, and sorting any board issues out. 

Kind regards, Conan. 

Link to comment
Share on other sites

  • 2 weeks later...
dwcraig1 said:

I guess your talking about a pin in the balance plug that's on the board. Is it getting bent inserting the battery at an angle perhaps?

It must of been getting bent, I checked them before sending off for repair, as I wanted to sort it myself if I could as I am in the UK, plus Evolv has a big workload, and I did not want to add unnecessary work to the company. 

But, now the pins have all been raised, it is staying in balance, and working fine. 

I am glad I sent it in though, as before, I tried this and it was reading out of balance still, evolv replaced the board and have done a much better job than the original manufacturer did. 

So, functioning fine and is in my rotation of DNA200's again. Liking the new firmware, the ability to change the screen to display the temp mainly instead of watts, I find that I change temp more often than power, I don't use very high power, it is rare for me to go over 50W, so the new firmware enabling easier temp changes is quite good I must say :).
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...