Jump to content

[Solved: loose nuts] "Loose" 510 threading on sdna75


a1
 Share

Recommended Posts

I have 3 sdna75s and just one of them has a strange issue with the 510.

When I screw an atomiser on it screws down all the way but has a slight rattle after the atomiser is fully seated,
there is also a little bit of give - ie: I can turn the atomiser a couple of mm back and forth even though the atomiser is fully connected.

It`s almost as though the threading on the 510 is too "loose" if that makes any sense.

The same atomiser(s) do not have the problem on the other two sdna75s - they screw down and stay still, no rattle.

Any smart ideas how to fix this without returning the unit ?

Thanks

Edit: Putting a thin o-ring between the mod and atomiser base works, but it`s not very graceful, leaving a gap and being a bit of a nuisance.

Link to comment
Share on other sites

Thanks DWCraig

now i`ve seen it`s comparatively easy to access, I`ll check that out and make sure it`s tight.

Edit: Hallelujia - that fixed it.

I wouldn`t have guessed it was that as there seemed to be no give in the main 510 fitting itself, at all.

A very hard quarter turn of the nut seems to have solved it though, Thanks Craig !

Edit 2:  I have to add, that although it cured the problem, it didn`t do it as I would have hoped.

I don`t think the 510 was loose at all, but tightening up the 510 nut has pulled the connector right in, so much so that the base of the atomiser is now touching the top of the device and friction alone against the rubberised coating is holding it still.

Rather that hadn`t happened as I would have liked to have kept the top of the device free of wear and scratches from screwing atomisers on & off.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...