Jump to content

Odd fault with new DNA250C board


Recommended Posts

Hi All,

This is my third attempt at making my own 3d printed mod 🙂 the Lipo version i designed just didn't work with the size that i wanted the mod to be, and the wiring was just too fiddly to do, and i ended up blowing the board and probably the Lipo cells when i tried to directly solder the wires to the board !

I've tried using battery tubes and that didn't turn out how i wanted it, so i'm back to dual 18650's in a sled.

I'll try to upload some pics, but i seem to fail at that every time too 🙄

Anyway, my problem ... when the board goes to sleep after a period of time (I haven't actually timed it) the board just goes completely dead, and it's really dead as if i plug a USB cable into it, my PC doesn't even recognise a connection.

The only way to revive it is to remove a battery, then immediately re-insert it, the board will then work absolutely fine until i leave it sat for a while.

One of the things i've noticed is that each time it does this, the resistance resets to settings that was uploaded when i copied the profile to the board from Escribe.  

Oddly, if i plug the USB cable into the board and leave it connected, the board will always wake up no matter what time has elapsed.

Looking at all the numbers in the device monitor, everything is working, it's charging both cells fine and all the rest of the settings are basically the same as any of my other mods - all of which use pretty much the same profile with the same battery profile and material profiles.

All my wiring looks ok to me (i'm not great at soldering, just OK ! )  ... and logically speaking if it were not good then it wouldn't actually work, which it does fine until it decides it doesn't want to come back on ! 😬

I sort of hope it's not a faulty board as i had to buy this from Germany as the 2 usual places in the UK were out of stock.

I'm not sure if StealthVape would look at this if it came from another country, and thoughts on that ?

Has anybody come across this type of problem ? or have better ideas than me on how to diagnose the issue ?

Thanks for any help 👍












Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...