Jump to content

A strange problem with Therion 75C's 510 connector


Recommended Posts

Hello! I wasn't sure where to write this, but I figured someone here might know of this problem or a way to fix it.

I've been trying to troubleshoot an issue with my new Therion 75C mod. In fact, this is a problem I also have on my older Therion 166, but it's a bit less-pronounced on the new one, and on the older device I actually have a bit of damage that related to the problem (but no damage on the new one).

The problem:

When I screw an atty and tighten it all the way, at the very end of this process I can hear a "clicking" sound. Once that happens, there seems to be a tiny movement I can produce by rotating the atty clockwise/counter-clockwise. It probably moves less than a mm in each direction, but this can definitely be felt and it seems the grip of the 510 connector is not full when this happens.

What's weird is that if I unscrew the atomizer a TINY bit, the grip becomes perfect. I really can't explain why this happens, but now every time I screw my tank I do a full tightening, then carefully turn it back ever so slightly so that it remains in a firm position with no movement whatsoever. I've also tried using a plastic insulator on the bottom of the atty - in fact I had to sand it for a while so that it would make contact, and it works perfectly but still leaves me with the same problem. This indicated that it's not a problem related to the length of the atomizer pin, because the insulator shortens that quite a bit and I am still left with the same issue. 

Also, I've tried my tanks on other mods and there is no movement. I also tried different atties on this particular mod - and there was movement with each one. This led me to believe the problem is 100% related to the 510 connector on the Therion.

If anyone has an idea on why/how is this happening - please let me know! So far I've tried looking for a screwdriver that can actually fit the 3 screws on top of the 510 connector, so I can tighten them if needed, but I haven't been able to find one. I am not sure why Lost Vape decided to put such obscure types of screws there, but I still can't find a screwdriver that would fit them.

Anyway, the issue is not fatal as all tanks still make a good connection, and with my method of reversing the tightening a tiny bit I seem to get a perfect grip. Yet, I'd like to be able to just tighten the tank normally and be done with it. I am also worried the issue might get worse with time. 

Do you think it could be something that needs me to disassemble the mod and re-solder something inside? 

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...