Jump to content

Paranormal 250c won’t power on


Djolf
 Share

Recommended Posts

I recently bought a Lost Vape Paranormal from VaporDNA. It seems to have trouble powering on sometimes. About four times a day, usually in the morning, it won’t turn on. At first I thought it was a hardware issue, but once it’s on it has no issues, the fire button works every time without fail. Which leads me to think it’s a firmware or settings issue. I have been using the latest escribe on a Mac. It didn’t do it at first and has gotten worse after the latest service package I installed. Is anyone else having this issue? If so, how did you fix it?

Link to comment
Share on other sites

I'm having the same issue. Sometimes if I let the mod sit for a while and it turns off (completely turns off, not just the screen going dark), it will refuse to turn back on. Plugging it in to a USB power source will wake it back up, but that's a horrible "fix" to the problem. Firmware version is 1.1 SP33 INT, with revision code: 311103368

I actually jumped on here to see if they posted patch notes for the latest firmware revision to determine if the issue had been addressed before I installed it...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...