Jump to content

Yet another Bricked MOD. Will not turn on, USB plug sometimes wakes it up..


Bricker89
 Share

Recommended Posts

you guys make like the worst MODs. I've had Chinese clones for $18 that were more reliable. 4 of of the ~5 DNA mods I bought have BRICKED in no time, about 9-13 months and I don't use them much or abuse them or vape high temperatures etc, had to warranty all of them. I made many threads for help here (w another account lost log in info when windows 8.1 machine crashed). 

 

This one now have barely used in the past year, a ThinkVape Finder 250c triple 18650.

The only one that hasn't given me problems is my original DNA 75 HCigar VTC nano. 

This problem has happened before: batteries have power but press the buttons and nothing lights up, not in stealth mode either. Sometimes plugging the USB in wakes it up and the problem goes away for a while. This one will not. Warranty ran out a while ago but I've had evolv grant warranty for expired MODs before thankfully. 

 

The ONLY reason I really buy DNA is because I can safely USB charge them, I dislike having to remove batteries and charge separately. I fully charged these 3 genuine pink 18650s in a nitecore charger and it still won't wake up. I do appreciate small tweaks in escribe but these DNAs have been a problem, stick to making potato light bulb projects or something. 

Any suggestions to try and wake this mode up?

thanks

 

Link to comment
Share on other sites

I purchased the following Evolv products.

OTHER (8)
x2 iTaste SVD2 DNA20
x4 Lost Vape Orion Pod Mod (40W Boost)
x2 Evolv Reflex

DNA40 (5)
x2 Hana One Modz DNA40 large screen
x2 HCigar HB40 DNA40 V5 small screen
x1 Vape.Tools Railbox DNA40 small screen

DNA60 (6)
x4 SXK Billet Box DNA60 w/USB
x1 XvoStick DNA60
x1 SXK Supbox DNA60

DNA75 (8)
x5 Kanger K1 DNA75
x2 Lost Vape Skar DNA75
x1 HCigar VT75 Inbox Squonk Kit DNA75 (Red)

DNA75C (12)
x4 Lost Vape Therion BF DNA75C
x1 HCigar VT75D DNA75C
x2 Lost Vape Mirage DNA75C - Black/Green Agate
x5 Dovpo Odin Mini DNA75C

DNA200 (15)
x5 HCigar VT133 DNA200
x2 HCigar VT200 DNA200
x2 Wismec Reuleaux DNA200
x4 Hotcig DX200 DNA200
x2 Lost Vape Triade DNA200

DNA250 (1)
x1 Wismec Reuleaux DNA250 Limited Edition

DNA250C (25)
x3 Lost Vape Paranormal DNA250C Standard Version
x3 Lost Vape Triade DNA250C (300W)
x2 Lost Vape Drone DNA250C
x2 Think Vape Finder DNA250C (300W)
x4 Lost Vape Centaurus DNA250C
x5 Dovpo Odin DNA250C
x4 Dovpo Top Gear DNA250C
x2 Dovpo Riva DNA250C

~~~
80 Total
~~~

None of them ever bricked on me. I sure like to know what you are doing with them.

  • Like 1
Link to comment
Share on other sites

maybe it's because I USB charge them? I asked that with my older account , but this one won't even turn on. It turned on fine the other day, said like %4 battery life, I plugged it in USB it light up, wasn't sure if I could see the little charging lightning bolt symbol in the battery box but then after that it hasn't turned on again. I didn't leak juice into it that I know of, especially since last plugging it in there wasn't even a tank on it and it's been just sitting on a shelf with no tank on it for months before this, in a cool room. 

 

Bill, that's a neat magnetic charger piece, I think I need one for my cell phone is sorta starting to go. The port on the mod seems fine, and I charged the cells to %100 in externals, but as mentioned sometimes it still needs the USB plug to wake it up so maybe the USB port IS dead.

 

 

Edited by Bricker89
Link to comment
Share on other sites

yes, I tried doing Lost Password and have it emailed to me but the email I used for that account is expired, stupid mail.com (and pretty much every other email service these days) auto deletes accounts if not logged into for 6 months. The email I used for all my e cig forum stuff (vaping underground forum etc) was a burner email I made just to create accounts and I never logged back in - this is stupid in case someone is sick for a few months or something like that or goes on a long vacation or something they could loose their very important bank email or something like that, and one can beg for the account to be re opened but they'll keep saying there's nothing they can do. 

 

anyways, I guess next is I'll try opening the mod and cleaning with a tiny bit of gentle electronics cleaner?

 

I have a whole bunch of micro USB-to-USB chargers, some are barely used and not compromised,  and I use only UL listed wall adapters (UL and sorta CE are the reliable ones, kinda hard to buy separately on ebay/amazon compared to the popular cheaper ones that could potentially over power what they're supposed to do or cause fires etc.  

Link to comment
Share on other sites

any suggestion how to actually fix this?

 

I didn't disassemble yet and unsure what that would accomplish, or which if any cleaner would be safe, mass air flow sensor cleaner for cars? electronics cleaner spray? % isopropyl?.

Wasn't dropped and doubt will find something disconnected.

 

Remember, plug into PC USB doesn't wake it up, so I can't do anything in eSCribe   

Link to comment
Share on other sites

You are referring to your ThinkVape Finder 250c, right? Did you try connecting to EScribe without the batteries installed? One of my ThinkVape Finder 250c, the positive of the battery pack was pinched and after 3 hours of use, the wire shorted to ground (the batteries must have added just enough pressure on the insulation). I'm glad I noticed the batteries getting hot and I ejected them right away. The thickness of their wiring is too thin IMHO. So I wouldn't be surprised if there was an open or heaven forbid a short in the wiring. But I would check to see if EScribe sees it without batteries first.

Link to comment
Share on other sites

thanks but plugging it in without batteries did nothing. 

I opened the whole thing and it's clean and all wiring looks fine. 

As I'm smoking a cigarette, anyone know of any other brands that are dual/triple 18650 that I can safely USB charge?! I'm sick of these DNAs breaking, this is like the 5th one.

I'll give it a shot if evolv will warranty this , they did it last time with a HCigar VT250s DNA200 which broke again or something and I had to resell it and hoped the DNA250C newest version would solve this BS. 

Link to comment
Share on other sites

Make/Model of Device (ie EFusion DNA200): DNA250C
Manufacturer of Device (N/A if board only): Thinkvape Finder

Message:

thinkvape finder 250c bought from efun.top with paypal about a month ago received DOA.

this dna250c is not turning on with known-good cells. Plug it into usb gives CLOCK ERROR CLOCK ERROR 4% battery, Tried holding all button configurations, firing 20X etc does not turn on without USB but then can't even use it with %100 charged cells says 4% and only lets you cycle through kanthal/watts/replay etc

then, giving Check Battery when I fire, it only turns on if USB connected. I reset to default escribe.
escribe is set to 3 cell and all 3 show 0.00V.

 

_____________________________________________________________________________________________________

apparently this MOD was already serviced by warranty around Sept 2019 when I bought it from etopfun it was received dead on arrival. I barely used it at all since getting it back from evolv. I'll try to see if they can do something about this POS.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...