JohnnyBigodes

Therion 166W doesnt work on windows 10 anymore?

Recommended Posts

Hello guys,

today I tried to connect my Lost Vape Therion 166W to 2 different PCs with Windows 10 and the result seems to be the same.

At first it gets recognized, but when you try to upload any settings through escribe the device stops working.

It seems that it deletes the USB driver, so that the device stops beeing recognized.

Even tried to install the drivers again but it wont work. (Error = Unknown USB device)

Is there anyone with the same problem or is my DNA250 not good anymore?

Thanks in advance for your responses.

Anmerkung 2019-05-21 195450.png

Anmerkung 2019-05-21 195543.png

Share this post


Link to post
Share on other sites
vor 2 Stunden schrieb dwcraig1:

First thing would be to try a different cable.  External USB hubs can be a problem too.

Yes I already tried different cables and different ports.

Nothing helps... Seems that my DNA is broken.

I still can charge it through USB and vape on it, but i cant change any settings on escribe.

Share this post


Link to post
Share on other sites

The last time I read about a member with this problem they were using an older version of EScribe from before the 250 came out. Is your version one that works with a 250?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now