Two DNA200's displaying 'check atomiser' on the same day.

Recommended Posts

Hi everyone. 

Today I decided to use one of my DNA200's as I have not used them in a while owning so many mods.

I downloaded the latest Escribe as the version I had would not open with OS Mojave and connected my  DNA200's to make sure they connected.

  I chose a Hotcig V1 with dual 18650 adapter to use for the day first, connected to Escribe , disconnected and tried to use it. 

Straight away, it displayed 'check atomiser' when I pressed the fire button- this was before an Atty was in place. It displayed the same thing with some connected that I know to work with other devices. 

So, I decided to use the Hotcig V2. Same thing. 'Check atomiser' with RDA's and RTAs I know to work. 


Any idea what is going on? Is it a coincidence that both are showing the same error? 


I like my mods that use Evolv boards when they work, but by far they have been the most unreliable for me which is a shame as they are also my most expensive mods. 

Share this post

Link to post
Share on other sites

Assuming they worked OK before sitting I'd start by cleaning/polishing the end of the mod's 510 positive pin. If that doesn't do it I'd check the solder joints board to 510 looking for corrosion.  Does Atomizer Analyzer show any connection? 

  • Like 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now