Brandon

About Orions that stop responding

Recommended Posts

22 minutes ago, dwcraig1 said:

5 clicks is to turn off/on is the default setting,  it can be changed in EScribe

O ok ty. Yea never hookd mine up to escribe & no plans on it.. It has everything rite out the box😀

Share this post


Link to post
Share on other sites

I just got my Orion DNA go today and accidently flooded it literally out of the box... Got a new pod because the cotton membrane was fucked kept flooding even when I cleared it out.... Now my device blinks red 4x and does nothing upon pressing fire/adjust button... I'm extremely pissed because flooding a pod shouldn't kill the entire mod.. ANY HELP PLEASE? I can't even find anything that says why it would even beep red 4x and do nothing..... This can't be normal

Share this post


Link to post
Share on other sites

No it is plugged up to the computer right now with a green/blue light .. Nothing is registering as connected on escribe (can't hard reset) even tho it's charging... And my device just blinks red 4x I don't understand am I being scammed... This literally came in the mail today

Share this post


Link to post
Share on other sites

I've used two different micro USB cables plus the one they shipped and none can detect my device... Also the device has been charging for over 3 hours and green light will not turn off (still beeps red/autolocks upon firing and power adjustment button no longer works) seems like these are very faulty even tho the [functioning] product was amazing.. am looking to get a refund or FREE fast fix. (For how much this device costs...). otherwise I'm taking back the charge through my bank and reporting them 

Share this post


Link to post
Share on other sites

Hi there! I have had this problem for a few weeks and the Facebook support stopped responding. I am unable to submit a ticket, I have tried multiple multiple times and it never goes through for some reason. I've never seen anything like this happen and I can't seem to get help. I've been waiting since before Christmas to get my vape fixed 

Share this post


Link to post
Share on other sites

I now have 2 dead, brand new Orions. Yes, the cable is good and works on other mods. Yes, I tried clicking 5 times. Yes, I tried charging them. No, EScribe won't connect to them. No, they don't work. I love my DNA's, but this just makes me angry.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now