loggo

HCIGAR-VT75D SCREEN PROBLEM.

Recommended Posts

Hi all, I wonder if you experts can help me here? I turned my vt75d on after a month or so only to find this strange black blob on the screen .  Could any one shed some light on this and please tell me it's not completey F*%ked!!

Any help would be welcome. Thanks.

20181009_203101.jpg

Share this post


Link to post
Share on other sites

Last time I buy a hcigar mod! I see the screens aint that exspenisive to buy, so I may as well have a stab at fixing it. Thanks for the imput guys.

Share this post


Link to post
Share on other sites
16 ore fa, loggo ha scritto:

Last time I buy a hcigar mod! I see the screens aint that exspenisive to buy, so I may as well have a stab at fixing it. Thanks for the imput guys.

HCigar has nothing to do with it, the screen is produced by Evolv. And even here I have some doubts, most likely Evolv buys screens from third parties.

Edited by mjordan79

Share this post


Link to post
Share on other sites

Yes - the placement of the 510 connector on the Hcigar VT75D is "suboptimal" ..... if you use an atomizer that may leaks e liquid can easy drop into the mod or the display ...... i had exactly the same problem 

After opening the mod for the screen replacement i found a some e-liquid inside of the mod! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now