Johann VB

Lost Vape Paranormal DNA 250 won't charge via USB

Recommended Posts

Hello there,

I bought recently a Lost Vape Paranormal DNA 250 with 2x LG HG2 18650 3000mAh (brand new).

For 1 week everything was all right, I charge it through USB without any problem.

Now when I plug it (on computer, on charger, I tried with many), it blinks in red 3 seconds more or less, then turn to green as if it was fully charged.

When I start EScribe, here is the result. As you will notice the USB power and current are both at 0.

image.thumb.png.cd5c6e04cf20c51c0235c22089749808.png

I tried a firmware update / USB Recovery Charge.

I tried to charge the batteries with a battery charger and they charge (except it takes 10 hours because I've got a charger for 1 battery only).

And sometimes... miracle... it charges again, without obvious reasons . But better not to unplug it at this moment or it will probably won't work again...

Would you have an idea on this issue? Don't hesitate if you need more data.

PS : The peaks in the cells voltage only appear if the USB charging is enabled, if not, the values are stable around  3.5 - 3.6 volts.

Thank you in advance,

 

Johann

 

Edited by Johann VB

Share this post


Link to post
Share on other sites

WOW.... new device only 1 week old.....15,930 vapes in one week.... that's 2,275 vapes per day.... (94+ vapes per hour x 24 hours per day x 7 days) OR did you mean only the batteries were brand new)

Definitely a problem....... could be many reasons.... anything from bad wiring, lose grounds, battery sled issue, e-liquid on the board, board issue, and etc..........if device is only 1 week old you might see if vendor will replace it.... cell 1 and cell 2 are not balanced.... your DM screenshot shows it not charging.... and you can start a ticket with Evolv....

Share this post


Link to post
Share on other sites

The problem started after 1 week (1st time it happened), it happened a few times since that, not enough for me to pay so much attention, now it's (almost) impossible to charge it since 2 days. The cigarette is maybe 1 month old (still a lot of vapes I know).

Thank you for your answer! Not really precise though :( 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now