Recommended Posts

Greetings fellow DNA user

i am really new to this DNA world, just coming from regular 35$ ish mod, and really happy to use this paranormal with dna 250c

and as we might know, the featured benefit is replay mode right ?

i use digiflavor drop RDA with SS316 with nominal cold resistance rating at 0.15 ohms, at first when  i switch to replay mode, the mod will fire really weak no matter how high wattage i put into, and after tinkering for awhile, and with basic knowledge that SS wire resistance will increase after heated, i push measure ohm on the setting and it reads 0.17.  it fires great and i able to save it. world just work like a charm at that time.

problem is, after i stop vaping for a while, let say 20 mins. the coil reading will return to 0.15 (as temp cooled down), then it wont fire as great as before (weak firing) even the replay mode is still turned on from previous vape, until i push measure ohm again and re read 0.17 ohm, it will fire great again.

i have tried to lock the resistance when it reads 0.17 and on 0.15, still no fix though. kinda frustrating if i have to re measure everytime i start vaping after long rests.

is anyone having this kind of problem too ? or this is a known issue bug ? or may my understanding about TC is wrong at this moment ?

your suggestion is so much appreciated, thanks for reading my rather long post

cheers😁

Share this post


Link to post
Share on other sites

I'm having the same issue with a siren 2 also with ss316

I thought it was a hot spot and made a new coil with the wires spaced. I can't get above 15w in replay.. 

Share this post


Link to post
Share on other sites

Check your mod resistance, calibrate if need be. The Drop RDA works perfectly with SS316 for me, I'm running a .064 build in it at the moment

Share this post


Link to post
Share on other sites

Thank you.. 

And how do I calibrate the mod? It reads 0.004 ohm and I don't have any courage to tinker with my current knowledge.. some guidance is so much appreciated.. 

Share this post


Link to post
Share on other sites

0.004 ohms is a pretty consistent calibration on many, many devices.... yours may already be done...

Share this post


Link to post
Share on other sites
9 hours ago, WhiteLies said:

Thank you.. 

And how do I calibrate the mod? It reads 0.004 ohm and I don't have any courage to tinker with my current knowledge.. some guidance is so much appreciated.. 

I agree with retird, but I'm also wondering what mod you have? My paranormal was set to .004, but I brought it down to .0038; my friends paranormal was also set to .004 but I took her down to .0017 to get a correct ohm reading.

Before tinkering with mod resistance perhaps see how ohm reading vary between your 250c and some other mods. If they are reading about the same resistance, then try running case thermals(be prepared to wait) in escribe. 

Also where did you source your SS316? Are you running in wattage mode on replay? What kind of build do you have in there (like Clapton or gauge)?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now