888Gavin

Phantom Button Presses on Lost Vape Triade DNA250 -- Help!!

Recommended Posts

Hey everyone, I'm having some trouble with my Lost Vape Triade DNA 250.  I was charging it last night, now all of the sudden there are "phantom button presses".  The wattage up button seems to be pressing itself, because every time I try to fire the device the screen shows the error " POWER LOCKED, HOLD UP DOWN"  and it simply won't fire.  When I unlock the power, the wattage rolls up to the maximum.  What could be the problem?  I have been finding juice all over the device while using it...  Do you think there is juice on the PCB, causing these button presses?  If so, what do I do??  Thanks in advance for reading and commenting.  Any help is appreciated.  Thanks!!

Share this post


Link to post
Share on other sites
49 minutes ago, 888Gavin said:

I have been finding juice all over the device while using it...  Do you think there is juice on the PCB, causing these button presses?  If so, what do I do??

YES!!

Clean it as best as you can ........... everywhere. Isopropyl alchol. If you're brave enough to open it up, even the buttons come apart to clean. Blow it out with compressed air if you have it and even lay it flat (vent slats down on one side) while blowing in the other side.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now