Jump to content

Lost Vape Paranormal issues


Recommended Posts

Hi All,

Just bought a Paranormal 166 (my Therion 166 just died :( battery terminal fell to bits)

But it's just not working at all properly in temp mode (all I use)

so ..

Got it out of the box, loaded the same titanium profile I use on the Therion, added the same batteries (Samsung 30Q's) and replicated the settings from the Therion (so effectively it should be almost exactly the same) - oh yeah using the exact same attys.

But it just won't play ! ... it seemed to be pulsing ... really badly, 1 second on one off.

Tried a few "Reset to default" and Re-applying the SP , it actually bricked last night after a reload, it would only show the Evolve 250 text then turn off, luckily I discovered that if I plugged it back into the PC, switched it on, it "booted up" so was able to do another SP reload, which brought it back to life ! YAY.

This morning I ran the Case Analyser so it now also has the correct settings in there, but it still will not vape correctly.

here are some screen shots of most of the relevant info (I think)

Here is what happens when trying to vape it.



A couple of oddities are that

A) the Paranormal is not reading the resistance of my tank\coil correctly, the cold resistance is always .14 (as read from my spare IPv4 and my tester) but the Paranormal is reading it at .19 to .20

B) the temp setting is way off, i'd normally be vaping the Therion at 240c, on the Paranormal I have to drop the temp down to 115 - 130c else it dry burns !!

C) the "Temp Protect" message never appears on the screen.

I've spoken to the shop I bought it from (via email) and got the standard sort of reply back "it's probably something you have set wrong" I tried to explain the above but the have not replied since !

Could there be something in the settings that is causing this ? .. I don't personally think so, i've checked\changed everything possible.

Or is this more likely a faulty device ?

Any help appreciated.




2017-12-21 19_04_29-Device Monitor - Evolv DNA 250.png

2017-12-21 19_05_36-Settings.png

2017-12-21 19_06_36-Settings.png

2017-12-21 19_06_57-Settings.png

2017-12-21 19_06_08-_ EScribe - Evolv DNA 250.png

Link to comment
Share on other sites

Ohhh iAlexander you are a star !! :)

Yep, cleaned the threadlock from the threads and all is good in the world !!

+ 1 for iAlexander  - 1 for Lost Vape for being numpties for putting a non conductive material between possibly the most important part !

Many thanks


  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...