Therion166

Therion 166 functions but only cycles

Recommended Posts

Hey everyone, 

I just purchased my first DNA 166 Therion box and I've already run into an issue sadly. 

I connected the device to the eScribe software and it automatically updated everything (we were fine at this point.)

After this, I clicked the disconnect button, allowed that command to process, then diconnected the device (physically) from the usb port.

Now, my Therion 166 will now fire and when attempting to turn the device on, it only flashes and cycles through:

CHECK BATTERY and 55.0 watts. The battery also shows that there is no juice left in the batteries but they operate fine on other devices. Is my device dead? Is there anything that can be done or do I send it back? I really don't want to since I'm in love with this thing but I'm noit sure what to do. HELP!

Share this post


Link to post
Share on other sites

Additionally,

When connected to the eScribe software, I can do the button simulation which successfully allows me to move the wattage Up and Down but when simulating pressing the Fire button, I receive a Check Battery error. Not sure what my options are at this point. 

Share this post


Link to post
Share on other sites

Lastly,

The device successfully changes themes. However, the result is the same regardless The display shows the following: 

0.00 (Ohms) 

0.00V

0.0A 

 

Both batteries are reading at a consistent 4.08 volts. 

Edited by Therion166
additional information

Share this post


Link to post
Share on other sites
On 6/15/2017 at 11:56 PM, Therion166 said:

Hey everyone, 

I just purchased my first DNA 166 Therion box and I've already run into an issue sadly. 

I connected the device to the eScribe software and it automatically updated everything (we were fine at this point.)

After this, I clicked the disconnect button, allowed that command to process, then diconnected the device (physically) from the usb port.

Now, my Therion 166 will now fire and when attempting to turn the device on, it only flashes and cycles through:

CHECK BATTERY and 55.0 watts. The battery also shows that there is no juice left in the batteries but they operate fine on other devices. Is my device dead? Is there anything that can be done or do I send it back? I really don't want to since I'm in love with this thing but I'm noit sure what to do. HELP!

Solved. Downloaded the Therion 166W DNA software and reset the device. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now