Search the Community

Showing results for tags 'no power'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Resources
    • Themes and Custom Screens
    • EScribe, Software and Firmware
    • Manuals, Instructions, and Tutorials
    • Replay and Atomizers
  • DNA 250 Color
    • General Discussion
    • Modders' Forum
  • DNA 200 and 250
    • General Discussion
    • Installation and Assembly
  • DNA 75 Color
    • General Discussion
    • Modders' Forum
  • DNA 75
    • General Discussion
    • Installation and Assembly
  • DNA 60
    • General Discussion
    • Modders' Forum
  • DNA Go
    • General Discussion
  • Technical
    • Batteries and Charging
    • Connectors, Components, and Accessories
    • Report a Bug
    • Researcher Forum

Categories

  • Theme Park
    • DNA 60 Small Screen
    • DNA 60, 75, 200, 250
    • DNA 75 Color, 250 Color
  • EScribe
    • Atomizer Profiles
    • Settings
    • Translations
  • Custom Materials

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 1 result

  1. Hey everyone, I just purchased my first DNA 166 Therion box and I've already run into an issue sadly. I connected the device to the eScribe software and it automatically updated everything (we were fine at this point.) After this, I clicked the disconnect button, allowed that command to process, then diconnected the device (physically) from the usb port. Now, my Therion 166 will now fire and when attempting to turn the device on, it only flashes and cycles through: CHECK BATTERY and 55.0 watts. The battery also shows that there is no juice left in the batteries but they operate fine on other devices. Is my device dead? Is there anything that can be done or do I send it back? I really don't want to since I'm in love with this thing but I'm noit sure what to do. HELP!