Jump to content

Search the Community

Showing results for tags 'dead screen or dead board'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Resources
    • Themes and Custom Screens
    • EScribe, Software and Firmware
    • Manuals, Instructions, and Tutorials
    • Replay and Atomizers
  • Reflex
    • General Discussion
  • DNA 250 Color
    • General Discussion
    • Modders' Forum
  • DNA 200 and 250
    • General Discussion
    • Installation and Assembly
  • DNA 75 Color
    • General Discussion
    • Modders' Forum
  • DNA 75
    • General Discussion
    • Installation and Assembly
  • DNA 60
    • General Discussion
    • Modders' Forum
  • DNA Go
    • General Discussion
  • Technical
    • Batteries and Charging
    • Connectors, Components, and Accessories
    • Report a Bug
    • Researcher Forum

Categories

  • Theme Park
    • DNA 60 Small Screen
    • DNA 60, 75, 200, 250
    • DNA 75 Color, 250 Color
  • EScribe
    • Atomizer Profiles
    • Settings
    • Translations
  • Custom Materials

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 1 result

  1. about 2 weeks ago my screen of my paranormal started to make weird lines. the mod kept functioning so i thought, the hell with it. ofcourse like all things do, it got worse, where now at the point the whole screen has these lines and its flipped upside down, i allways use an external charger for my batts, never used the usb port for it, i also know for sure that my batts are ok. i did screw it open ( i work as a smartphone repair tech so i had all the right tools ) unplugged the screen, cleaned it and put it back together but still the issue remains. now my question is, is
×
×
  • Create New...