Search the Community

Showing results for tags 'charger'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Resources
    • Themes and Custom Screens
    • EScribe, Software and Firmware
    • Manuals, Instructions, and Tutorials
    • Replay and Atomizers
  • DNA 250 Color
    • General Discussion
    • Modders' Forum
  • DNA 200 and 250
    • General Discussion
    • Installation and Assembly
  • DNA 75 Color
    • General Discussion
    • Modders' Forum
  • DNA 75
    • General Discussion
    • Installation and Assembly
  • DNA 60
    • General Discussion
    • Modders' Forum
  • DNA Go
    • General Discussion
  • Technical
    • Batteries and Charging
    • Connectors, Components, and Accessories
    • Report a Bug
    • Researcher Forum

Categories

  • Theme Park
    • DNA 60 Small Screen
    • DNA 60, 75, 200, 250
    • DNA 75 Color, 250 Color
  • EScribe
    • Atomizer Profiles
    • Settings
    • Translations
  • Custom Materials

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 1 result

  1. Calexiou

    DNA200 not working

    Hi, I have been using the DNA200 for the last couple of months or so with no problems so far. This morning when I got it it felt a bit warm. When I press the fire button nothing would happen. The screen is not showing anything and the mod itself is not working at all. I removed the batteries and I charged them and now they are fully charged. The mod is still not responding. Any help would be appreciated thanks